Vswe's Summer Courses | You're not logged in. Sign up or log in | Server time: | Donate
One can now see other persons' badge hunts. Simply head over to their profiles to access them.

Go back to sub forum page

General forum

Non-course related subjects

3. Programming help

Release Error

  • 2014-01-14 08:38:27
    Whenever I try and compile the mod I do the...
    1. recompile.sh
    2. reobfuscate_srg.sh
    3. getghangedsrc.sh

    But whenever I try to add to to my minecraft it gives me the same error

    cpw.mods.fml.common.LoaderException: java.lang.ClassNotFoundException: mrolas.muchMoney.common.MuchMoney

    http://pastebin.com/aDn3Xcmm
  • 2014-01-14 08:40:50
    oh, and here's the source code if that has anything to do with it

    https://www.dropbox.com/s/4v71tue4b0l5et6/muchMoney_0.0.4_src.zip

    but everything seems to run fine inside of eclipse
  • 2014-01-14 18:06:18
    Not sure why that is the issue for you.
    I downloaded the src and recompiled it and reobfuscated it and the classes I get from that + the assets folder I put in zip and the mod loads and I can use the things ingame.

    To compile I needed to change an import in GuiPublicBank:10, you import something from another project: import mrolas.tutorialMod.common.block.Blocks;

    I took my time to test it a bit and I managed to crash it two different times.
    First: Shift right click into the Vault http://pastebin.com/degQh8bU
    Second: I had an item picked up and holding it with my mouse while clicking an tab in the Shop Stop http://pastebin.com/TYZ702JJ
  • 2014-01-14 18:50:31
    That's weird then and thanks for pointing those out. I'll fix them right away. In the mean time, do you think you could maybe try and run a zip that I recompiled and did that stuffs myself?

    https://www.dropbox.com/s/u5fb8cthc7tbg0r/muchMoney_0.0.5.zip
  • 2014-01-14 21:34:06
    I think I know what your problem is. Your mod is packaged like:

    muchMoney_0.0.5.zip
        > _MACOSX
        > muchMoney_0.0.5
            > mrolas
                > muchMoney
                    > etc.
            > assets
                > muchmoney
                    > etc.

    That will not work because you have the muchMoney_0.0.5 folder inside of the zip that has the package and assets folder inside of is.
    The package and assets folder needs to be right inside of the .zip and not inside of the muchMoney_0.0.5 folder in the .zip
    To make it to work you have to make the .zip something like this:

    muchMoney_0.0.5.zip
        > mrolas
            > muchMoney
                > etc.
        > assets
            > muchmoney
                > etc.
  • 2014-01-14 21:34:38
    Wait, no, this link
    https://www.dropbox.com/s/u5fb8cthc7tbg0r/muchMoney_0.0.5.zip

    the other one would throw exceptions because I hadn't gotten rid of that import
  • 2014-01-14 21:36:40
    ahhhh, that would make sense... I'll try that out real quick and tell you if that was the issue
  • 2014-01-14 21:53:34
    Yup. It works now. Thanks for the help :)
  • 2014-01-14 22:24:29
    No problem :P
    Got the same error as you did when running and then I looked inside of the .zip an realized what was wrong.

    The reason it couldn't find the class:
    mrolas.muchMoney.common.MuchMoney

    was because it was like this in the .zip:
    muchMoney_0.0.5.mrolas.muchMoney.common.MuchMoney
  • 2014-01-14 22:47:49
    but aside from all that jazz... You had a look at the mod, what do you think it so far?
    It's my first time actually putting a considerable amount of effort into creating a mod. In the past it has always been "Diamonds and stuff are hard to get so I'm gonna make recipes so I can make them out of other things that I can just farm".
  • 2014-01-15 02:08:44
    It looked good and had an interesting concept.
    I couldn't manage to use Bank, as it didn't have a Crafting Recipe I guess it's not finished.

    The Refinery crash on shift right click in items into it: http://pastebin.com/EnGWacDq
  • 2014-01-15 03:38:12
    yea, I forgot to add the recipe for it. the bank card, if you saw that, sort of acts like one of those storage cells from applied energistics. You put a bank card into the designated slot and the items show up in the inventory and only one person can open the gui at a time... at least it should be that way, I'm only one person so I can't really test that out
  • Log in or sign up to reply to this thread